关于Mac升级到10.13之后git命令提示missing xcrun错误的解决方法 有更新!

  |   8 评论   |   751 浏览

今天升级了MacOS High Sierra 10.13,之后打开我的IDEA,就提示Git错误,具体的错误信息如下

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools),
missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

解决方法:

只需要在终端下执行如下命令,在弹出的对话框中点击安装,等待安装完成即可!

xcode-select --install

如下图所示:

评论

  • maqingfu 回复»

    可以可以

  • TuChief @88250 回复»

    用来社区还有这问题,从来没去看自己同步到社区去的文章

  • TuChief @yangyujiao 回复»

    有图啊:joy:

  • 88250 回复»

    估计是暂时解决不了了..

  • yangyujiao 回复»

    就是说不能解决?

  • 88250 回复»

    社区是 HTTPS 的,原图是 HTTP 的,被浏览器阻止了。

  • yangyujiao 回复»

    9a5b7570e70c48559d16963e8737be5d-image.png

    刚去楼主的博客看了,是有图的,说明是没有同步过来呀。 @88250

  • yangyujiao 回复»

    我老早就在10.12.6,,, 现在还是。。。 一点想要升级的欲望都没有。。
    另外,图呢?
    cab26f2c0a7d47ee8489431324977160-image.png

发表评论

validate